Firmware v8.0.1 and legacy DIS central units

FAQ #4849 Updated February 03, 2016

Question:

Which central units is Firmware version 8.0.1 compatible with?

Answer:

Firmware version 8.0.1 is compatible with the DIS-CCU, CU 5905, CU 6105, and CU 6110.  It is not compatible with earlier central units.

Find an Answer

Related Product Types

Discussion Systems

Related Products

CU 5905

CU 6105

CU 6110

DIS-CCU

Contact Information

Telephone: (800) 516-2525

Fax: (847) 600-8686

Additional Support

Ask a Question